domingo, septiembre 17, 2006

compiz


compiz
Originally uploaded by miguel angel huerta gonzález.
Bien, mi tarjeta es una ATI Mobility Radeon, viene con una compaq presario x1000, y como es ATI significa problemas (claro hasta que ati libere los drivers).

Empecemos obteniendo informacion con lspci
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 01)

01:00.0 0300: 1002:4c66 (rev 01)

Despues de buscar un rato damos con esto:
http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide

Seguimos todos los pasos hasta que nos de el primer error:

./ati-installer.sh: 165: Syntax error: Bad substitution

Como a los de ubuntu se les da por cambiar todo y cuasi no avisar me entero que ya no se usa bash sino dash, lo cual no nos deja continuas con nuestra instalacion, bien, arreglemoslo, leyendo un poco esto
http://forum.ubuntu-fr.org/viewtopic.php?id=56948
sudo ln -sf /bin/bash /bin/sh
Y continuamos.

Si no seguimos bien los pasos obtendremos más errores, como el siguiente:
[fglrx] API ERROR: could not register entrypoint for

Que se arregla con:
sudo -s
cd /usr/lib/
mv libGL.so.1.2 libGL.so.1.2.orig
wget http://www.ground-impact.com/libGL.so.1.2
ln -sf libGL.so.1.2 libGL.so.1

Opciones importantes si tienes una compaq X1000 y se ve negra la pantalla de la lap en la seccion de devices de fglrx
Option "no_accel" "no"
Option "no_dri" "no"

Y al final para que podamos usar xgl
Section "Extensions"
Option "Composite" "Disable"
EndSection

Lamentablemente no pude hacer funcionar dos monitores, al parecer es un error del driver, tal vez cuando me compre un LCD tenga que hacerlo funcionar, mientras con uno me conformo con uno, lo bueno es que aumento como una pulgada mi resolucion :D.
Publicar un comentario